Discussion:
cups and samba stop working after upgrade to etch
(too old to reply)
Bill Shofner
2007-04-20 15:25:26 UTC
Permalink
After upgrading my sarge box to etch, I cannot print and samba no
longer works. When I re-boot I get the following message from root:

The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 2540 (/usr/sbin/smbd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Debian. For information about the procedure for submitting bug reports,
please see http://www.debian.org/Bugs/Reporting or the reportbug(1)
manual page.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1213147456 (LWP 2540)]
0xb7f3b410 in ?? ()
#0 0xb7f3b410 in ?? ()
#1 0x00000001 in ?? ()
#2 0x00000000 in ?? ()

I cannot print from the printer attached to this system either and when
I try to go to http://localhost:631 I get:

An error occurred while loading http://localhost:631:
Could not connect to host localhost (port 631).


I thought I would try nmap to see if it suggested anything - results
below:

L550r:/home/bill# nmap -FA L550r

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2007-04-20
10:55 EDT
Warning: Hostname L550r resolves to 2 IPs. Using 127.0.0.1.
Stats: 0:01:29 elapsed; 0 hosts completed (1 up), 1 undergoing Service
Scan
Service scan Timing: About 90.00% done; ETC: 10:57 (0:00:09 remaining)
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1229 closed ports
PORT STATE SERVICE VERSION
9/tcp open discard?
13/tcp open daytime
22/tcp open ssh OpenSSH 4.3p2 Debian 9 (protocol 2.0)
25/tcp open smtp Exim smtpd 4.63
37/tcp open time (32 bits)
111/tcp open rpcbind 2 (rpc #100000)
113/tcp open ident OpenBSD identd
515/tcp open printer
998/tcp open busboy?
10000/tcp open http Webmin httpd
No exact OS matches for host (If you know what OS is running on it, see
http://www.insecure.org/cgi-bin/nmap-submit.cgi).
TCP/IP fingerprint:
SInfo(V=4.11%P=i686-pc-linux-gnu%D=4/20%Tm=4628D4E1%O=9%C=1)
TSeq(Class=RI%gcd=1%SI=204424%IPID=Z)
TSeq(Class=RI%gcd=1%SI=2043CB%IPID=Z)
TSeq(Class=RI%gcd=1%SI=20440D%IPID=Z)
T1(Resp=Y%DF=Y%W=8000%ACK=S++%Flags=AS%Ops=MNNTNW)
T2(Resp=N)
T3(Resp=Y%DF=Y%W=8000%ACK=S++%Flags=AS%Ops=MNNTNW)
T4(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
T5(Resp=Y%DF=Y%W=0%ACK=S++%Flags=AR%Ops=)
T6(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
T7(Resp=Y%DF=Y%W=0%ACK=S++%Flags=AR%Ops=)
PU(Resp=Y%DF=N%TOS=C0%IPLEN=164%RIPTL=148%RID=E%RIPCK=E%UCK=E%ULEN=134%DAT=E)


Service Info: OSs: Linux, OpenBSD

Nmap finished: 1 IP address (1 host up) scanned in 124.605 seconds

This looks like the printer may be on a different port, so I tried
http:localhost:515 which gave:

An error occurred while loading http://localhost:515:
Connection to host localhost is broken.

At this point I do not know if the underlying problem is in cups or
samba or something else. Any pointers or suggestions will be greatfully
received.

Bill
Florian Kulzer
2007-04-21 19:50:43 UTC
Permalink
After upgrading my sarge box to etch, I cannot print and samba no longer
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 2540 (/usr/sbin/smbd).
This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.
[...]
I cannot print from the printer attached to this system either and when I
Could not connect to host localhost (port 631).
[...]
At this point I do not know if the underlying problem is in cups or samba
or something else. Any pointers or suggestions will be greatfully received.
Just to get this out of the way first: Are you sure that your upgrade is
complete? Did you use the procedure outlined in the release notes?
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill Shofner
2007-04-21 22:46:26 UTC
Permalink
Post by Bill Shofner
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
longer
Post by Bill Shofner
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 2540 (/usr/sbin/smbd).
This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which
shows
Post by Bill Shofner
the state of the program at the time the error occurred. The Samba
log
Post by Bill Shofner
files may contain additional information about the problem.
[...]
Post by Bill Shofner
I cannot print from the printer attached to this system either and
when I
Post by Bill Shofner
Could not connect to host localhost (port 631).
[...]
Post by Bill Shofner
At this point I do not know if the underlying problem is in cups or
samba
Post by Bill Shofner
or something else. Any pointers or suggestions will be greatfully
received.
Just to get this out of the way first: Are you sure that your upgrade is
complete? Did you use the procedure outlined in the release notes?
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Yes, I'm reasonably sure the upgrade is complete. I did use the
procedure in the release notes as closely as I could - it did involve
several itinerations of upgrade and dist-upgrade until aptitude
indicated there is nothing to upgrade. The kernel was upgraded last.

Bill
Florian Kulzer
2007-04-22 13:57:57 UTC
Permalink
Post by Florian Kulzer
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
The Samba 'panic action' script, /usr/share/samba/panic-action, was
called for PID 2540 (/usr/sbin/smbd).
This means there was a problem with the program, such as a
segfault. Below is a backtrace for this process generated with
gdb, which shows the state of the program at the time the error
occurred. The Samba log files may contain additional information
about the problem.
[...]
Post by Bill Shofner
I cannot print from the printer attached to this system either and
An error occurred while loading http://localhost:631: Could not
connect to host localhost (port 631).
[...]
Post by Bill Shofner
At this point I do not know if the underlying problem is in cups or samba
or something else. Any pointers or suggestions will be greatfully received.
Just to get this out of the way first: Are you sure that your upgrade
is complete? Did you use the procedure outlined in the release notes?
Yes, I'm reasonably sure the upgrade is complete. I did use the procedure
in the release notes as closely as I could - it did involve several
itinerations of upgrade and dist-upgrade until aptitude indicated there is
nothing to upgrade. The kernel was upgraded last.
OK, let's take a look at your system. Please post the output of this
command:

dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk '/^[^|D+]/{print $1,$2,$3}'

and just to be sure also include the result of:

uname -a
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill Shofner
2007-04-22 15:12:47 UTC
Permalink
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
The Samba 'panic action' script, /usr/share/samba/panic-action,
was
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
called for PID 2540 (/usr/sbin/smbd).
This means there was a problem with the program, such as a
segfault. Below is a backtrace for this process generated with
gdb, which shows the state of the program at the time the error
occurred. The Samba log files may contain additional information
about the problem.
[...]
Post by Bill Shofner
I cannot print from the printer attached to this system either
and
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
An error occurred while loading http://localhost:631: Could not
connect to host localhost (port 631).
[...]
Post by Bill Shofner
At this point I do not know if the underlying problem is in cups
or samba
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
or something else. Any pointers or suggestions will be greatfully
received.
Post by Bill Shofner
Post by Florian Kulzer
Just to get this out of the way first: Are you sure that your
upgrade
Post by Bill Shofner
Post by Florian Kulzer
is complete? Did you use the procedure outlined in the release
notes?
Post by Bill Shofner
Yes, I'm reasonably sure the upgrade is complete. I did use the
procedure
Post by Bill Shofner
in the release notes as closely as I could - it did involve several
itinerations of upgrade and dist-upgrade until aptitude indicated
there is
Post by Bill Shofner
nothing to upgrade. The kernel was upgraded last.
OK, let's take a look at your system. Please post the output of this
dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk '/^[^|D+]/{print $1,$2,$3}'
uname -a
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
L550r:/home/bill# dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk
'/^[^|D+]/{print $1,$2,$3}'
rc cups-pdf 2.4.2-3
ii cupsomatic-ppd 20050430-1
rc cupsys 1.1.23-10sarge1
ii cupsys-bsd 1.2.7-4
ii cupsys-client 1.2.7-4
ii cupsys-common 1.2.7-4
ii cupsys-dbg 1.2.7-4
un cupsys-driver-gimpprint <none>
un cupsys-pstoraster <none>
ii cupsys-pt 1.2.4-3+b1
un eggcups <none>
ii gnome-cups-manager 0.31-3
pn hotplug <none>
un kdelibs3-cups <none>
ii libcupsimage2 1.2.7-4
ii libcupsys2 1.2.7-4
rc libcupsys2-gnutls10 1.2.7-4
ii libgnomecups1.0-1 0.2.2-5
rc libgnomecupsui1.0-1 0.25-2.1
ii libgnomecupsui1.0-1c2a 0.31-3
ii libsmbclient 3.0.24-6
un libwcsmbs <none>
ii samba 3.0.24-6
un samba-client <none>
ii samba-common 3.0.24-6
ii samba-doc 3.0.24-6
un samba-doc-pdf <none>
ii smbclient 3.0.24-6
un smbfs <none>
un smbget <none>
un smbldap-tools <none>
ii udev 0.105-4
ii webmin-samba 1.180-3
L550r:/home/bill# uname -a
Linux L550r 2.6.18-4-686 #1 SMP Mon Mar 26 17:17:36 UTC 2007 i686
GNU/Linux


Hope you see something useful here. Thanks.
Bill
Florian Kulzer
2007-04-22 16:20:09 UTC
Permalink
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 2540 (/usr/sbin/smbd).
[...]
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
I cannot print from the printer attached to this system either
An error occurred while loading http://localhost:631: Could not
connect to host localhost (port 631).
[...]
Post by Bill Shofner
Post by Florian Kulzer
OK, let's take a look at your system. Please post the output of this
dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk '/^[^|D+]/{print $1,$2,$3}'
uname -a
[...]
Post by Bill Shofner
L550r:/home/bill# dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk
'/^[^|D+]/{print $1,$2,$3}'
rc cups-pdf 2.4.2-3
ii cupsomatic-ppd 20050430-1
rc cupsys 1.1.23-10sarge1
ii cupsys-bsd 1.2.7-4
ii cupsys-client 1.2.7-4
ii cupsys-common 1.2.7-4
ii cupsys-dbg 1.2.7-4
un cupsys-driver-gimpprint <none>
un cupsys-pstoraster <none>
ii cupsys-pt 1.2.4-3+b1
un eggcups <none>
ii gnome-cups-manager 0.31-3
pn hotplug <none>
un kdelibs3-cups <none>
ii libcupsimage2 1.2.7-4
ii libcupsys2 1.2.7-4
rc libcupsys2-gnutls10 1.2.7-4
ii libgnomecups1.0-1 0.2.2-5
rc libgnomecupsui1.0-1 0.25-2.1
ii libgnomecupsui1.0-1c2a 0.31-3
ii libsmbclient 3.0.24-6
un libwcsmbs <none>
ii samba 3.0.24-6
un samba-client <none>
ii samba-common 3.0.24-6
ii samba-doc 3.0.24-6
un samba-doc-pdf <none>
ii smbclient 3.0.24-6
un smbfs <none>
un smbget <none>
un smbldap-tools <none>
ii udev 0.105-4
ii webmin-samba 1.180-3
L550r:/home/bill# uname -a
Linux L550r 2.6.18-4-686 #1 SMP Mon Mar 26 17:17:36 UTC 2007 i686 GNU/Linux
The status of kernel, udev and hotplug seems to be OK.

As far as CUPS is concerned: I am surprised that the "cupsys" package
has been removed instead of upgraded to version 1.2.7-4. What is the
output of

apt-cache policy cupsys

I do not immediately see anything wrong with your samba-related
packages. You could try to restart it and hope for a more illuminating
error message:

/etc/init.d/samba restart

Finally, let's check if there are other broken packages on your system:

aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/ /g'
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill Shofner
2007-04-23 01:10:25 UTC
Permalink
Post by Florian Kulzer
Post by Florian Kulzer
Post by Bill Shofner
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba
no
Post by Bill Shofner
The Samba 'panic action' script, /usr/share/samba/panic-
action,
Post by Bill Shofner
was called for PID 2540 (/usr/sbin/smbd).
[...]
Post by Florian Kulzer
Post by Florian Kulzer
Post by Bill Shofner
Post by Bill Shofner
I cannot print from the printer attached to this system either
An error occurred while loading http://localhost:631: Could
not
Post by Bill Shofner
connect to host localhost (port 631).
[...]
Post by Florian Kulzer
Post by Florian Kulzer
Post by Bill Shofner
OK, let's take a look at your system. Please post the output of this
dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk '/^[^|D+]/
{print
$1,$2,$3}'
uname -a
[...]
Post by Florian Kulzer
Post by Florian Kulzer
L550r:/home/bill# dpkg -l \*samba\* \*smb\* \*cups\* udev hotplug | awk
'/^[^|D+]/{print $1,$2,$3}'
rc cups-pdf 2.4.2-3
ii cupsomatic-ppd 20050430-1
rc cupsys 1.1.23-10sarge1
ii cupsys-bsd 1.2.7-4
ii cupsys-client 1.2.7-4
ii cupsys-common 1.2.7-4
ii cupsys-dbg 1.2.7-4
un cupsys-driver-gimpprint <none>
un cupsys-pstoraster <none>
ii cupsys-pt 1.2.4-3+b1
un eggcups <none>
ii gnome-cups-manager 0.31-3
pn hotplug <none>
un kdelibs3-cups <none>
ii libcupsimage2 1.2.7-4
ii libcupsys2 1.2.7-4
rc libcupsys2-gnutls10 1.2.7-4
ii libgnomecups1.0-1 0.2.2-5
rc libgnomecupsui1.0-1 0.25-2.1
ii libgnomecupsui1.0-1c2a 0.31-3
ii libsmbclient 3.0.24-6
un libwcsmbs <none>
ii samba 3.0.24-6
un samba-client <none>
ii samba-common 3.0.24-6
ii samba-doc 3.0.24-6
un samba-doc-pdf <none>
ii smbclient 3.0.24-6
un smbfs <none>
un smbget <none>
un smbldap-tools <none>
ii udev 0.105-4
ii webmin-samba 1.180-3
L550r:/home/bill# uname -a
Linux L550r 2.6.18-4-686 #1 SMP Mon Mar 26 17:17:36 UTC 2007 i686
GNU/Linux
The status of kernel, udev and hotplug seems to be OK.
As far as CUPS is concerned: I am surprised that the "cupsys" package
has been removed instead of upgraded to version 1.2.7-4. What is the
output of
apt-cache policy cupsys
cupsys:
<Not -Installed>
Candidate: 1.2.7-4
Version table:
*** 1.2.7-4 0
500 http://ftp.debian.org stable/main Packages
100 /var/lib/dpkg/status

After seeing this I did an aptitude install cupsys and went to
http://localhost:631 and congigured my printer. I can now print from
this machine! Thank you very much!
Post by Florian Kulzer
I do not immediately see anything wrong with your samba-related
packages. You could try to restart it and hope for a more illuminating
/etc/init.d/samba restart
All this did was send another message from root about the "Samba panic
action script. Just to be sure, I re-booted the computer and got the
same message from root again. So samba is still not working.
Post by Florian Kulzer
Finally, let's check if there are other broken packages on your
aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/ /g'
L550r:/home/bill# aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/ /g'
i alsaplayer 0.99.76-0.3sarge1
i alsaplayer-common 0.99.76-9
i balsa 2.3.13-2
i dirmngr 0.9.6-1+b1
i foomatic-db-hpijs 20061031-1
i foomatic-filters-ppds 20061104-1
i g-wrap 1.9.6-3.1
i gksu 2.0.0-1
i gnome-bin 1.4.2-34
i gnucash 2.0.5-1
i gnupg2 2.0.0-5.2
i gpgsm 2.0.0-5.2
i gstreamer0.10-plugins-base 0.10.10-4
i gstreamer0.10-plugins-good 0.10.4-4
i gstreamer0.10-plugins-ugly 0.10.4-5
i guile-1.6-dev 1.6.8-6
i guile-1.6-slib 1.6.8-6
i guile-library 0.1.2-1
i hpijs-ppds 2.6.10+1.6.10-3
i kdemultimedia-kfile-plugins 4:3.5.5-2
i kfax 4:3.5.5-3
i kommander 4:3.5.5-1
i libakode2 2.0.1-2
i libasound2-plugins 1.0.13-3
i libavcodec0d 0.cvs20060823-8
i libavcodeccvs51 3:20070329-0.0
i libegroupwise6 1.0.4-1
i libft-perl 1.2-16
i libglade-gnome0 1:0.17-8
i libglade0 1:0.17-8
i libgnomeprint-bin 0.37-12
i libgnomeprint15 0.37-12
i libgnomeui32 1.4.2-34
i libgnorba27 1.4.2-34
i libmime-perl 5.420-0.1
i libofx1 1:0.7.0-7
i libopensc1 0.9.6-1
i libpt-plugins-avc 1.10.2-2
i libpt-plugins-dc 1.10.2-2
i libxine1 1.1.2+dfsg-4
i mplayer 1:1.0-rc1svn20070225
i xscreensaver-gl 4.24-5


--
Post by Florian Kulzer
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Thanks for your help so far.

Bill
Florian Kulzer
2007-04-23 19:25:22 UTC
Permalink
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
longer works. When I re-boot I get the following message from
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 2540 (/usr/sbin/smbd).
[ CUPS works now, samba does not. One down, one to go... ]
Post by Bill Shofner
Post by Florian Kulzer
I do not immediately see anything wrong with your samba-related
packages. You could try to restart it and hope for a more illuminating
/etc/init.d/samba restart
All this did was send another message from root about the "Samba panic
action script. Just to be sure, I re-booted the computer and got the same
message from root again. So samba is still not working.
Post by Florian Kulzer
aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/ /g'
L550r:/home/bill# aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/ /g'
[ snip: 42 broken packages ]

I think you might have to purge and reinstall samba, but first you
should fix the broken packages. (I did not see anything that I could
immediately connect to samba, but it is probably better to get this out
of the way first.)

The first thing to do is to tell aptitude to figure things out on its
own:

aptitude install -f

If this has nasty side effects such as scheduling the removal of half of
your system then you should abort the command (you will get that
opportunity in any case, don't worry) and post all output here. We will
then (hopefully) figure out how to proceed based on the symptoms.

If this command runs OK then you should verify that

aptitude search '~b'

finishes without finding any packages anymore. Once that is achieved we
will see about samba.
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill Shofner
2007-04-23 21:00:03 UTC
Permalink
Post by Florian Kulzer
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba
no
Post by Bill Shofner
Post by Florian Kulzer
Post by Bill Shofner
longer works. When I re-boot I get the following message from
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 2540 (/usr/sbin/smbd).
[ CUPS works now, samba does not. One down, one to go... ]
Post by Bill Shofner
Post by Florian Kulzer
I do not immediately see anything wrong with your samba-related
packages. You could try to restart it and hope for a more
illuminating
Post by Bill Shofner
Post by Florian Kulzer
/etc/init.d/samba restart
All this did was send another message from root about the "Samba
panic
Post by Bill Shofner
action script. Just to be sure, I re-booted the computer and got the
same
Post by Bill Shofner
message from root again. So samba is still not working.
Post by Florian Kulzer
Finally, let's check if there are other broken packages on your
aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/ /g'
L550r:/home/bill# aptitude -F '%c %p %20v' search '~b' | sed 's/ \+/
/g'
[ snip: 42 broken packages ]
I think you might have to purge and reinstall samba, but first you
should fix the broken packages. (I did not see anything that I could
immediately connect to samba, but it is probably better to get this out
of the way first.)
The first thing to do is to tell aptitude to figure things out on its
aptitude install -f
If this has nasty side effects such as scheduling the removal of half of
your system then you should abort the command (you will get that
opportunity in any case, don't worry) and post all output here. We will
then (hopefully) figure out how to proceed based on the symptoms.
If this command runs OK then you should verify that
aptitude search '~b'
finishes without finding any packages anymore. Once that is achieved we
will see about samba.
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
L550r:/home/bill# aptitude install -f
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages are BROKEN:
alsaplayer alsaplayer-common balsa dirmngr foomatic-db-hpijs
foomatic-filters-ppds g-wrap gksu gnome-bin gnucash gnupg2 gpgsm
gstreamer0.10-plugins-base gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly guile-1.6-dev guile-1.6-slib guile-library
hpijs-ppds kdemultimedia-kfile-plugins kfax kommander libakode2
libasound2-plugins libavcodec0d libavcodeccvs51 libegroupwise6
libft-perl
libglade-gnome0 libglade0 libgnomeprint-bin libgnomeprint15
libgnomeui32
libgnorba27 libmime-perl libofx1 libopensc1 libpt-plugins-avc
libpt-plugins-dc libxine1 mplayer xscreensaver-gl
The following packages will be REMOVED:
alien alsaplayer-esd alsaplayer-oss cupsomatic-ppd debconf-utils
debhelper debian-reference-common debian-reference-en dfontmgr
flashplayer-mozilla foomatic-db foomatic-db-engine foomatic-filters
gcc-3.3-doc gcc-3.4-doc gconf gettext gnome-audio guile-1.6 hwdata
intltool-debian liba52-0.7.4 libart2 libbonobo2 libcompfaceg1
libconvert-binhex-perl libdate-manip-perl libdirectfb-0.9-20
libdivxdecore0 libdv4 libdvdread3 libefs1 libgal2.2-1
libgal2.2-common
libgal23 libgconf11 libgdk-pixbuf-gnome2 libgdk-pixbuf2 libghttp1
libglade-perl libgle3 libgnome-vfs-common libgnome-vfs0 libgnome2-doc
libgnorbagtk0 libguppi16 libgwrapguile1 libimlib2 libkpathsea3
libksba8
liblame0 libltdl3 libmikmod2 liboaf0 libofx0c102 libopenct0 liborbit0
libosp4 libpcsclite1 libsamplerate0 libshout3 libsoup2.2-7 libsqlite0
libswt-mozilla3-java libswt-mozilla3-jni libsysfs1 libt1-5 libtheora0
libtiff-tools libttf2 libwww0 libxml1 libxvidcore4 oaf po-debconf
psfontmgr realplayer samba-doc sudo ttf-freefont w32codecs webmin
webmin-inetd
0 packages upgraded, 0 newly installed, 83 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 146MB will be freed.
The following packages have unmet dependencies:
libofx1: Depends: libosp4 (>= 1.5.1.0-1) but it is not installable
gnucash: Depends: libltdl3 (>= 1.5.2-2) but it is not installable
Depends: libdate-manip-perl but it is not installable
Depends: psfontmgr but it is not installable
gstreamer0.10-plugins-ugly: Depends: liba52-0.7.4 but it is not
installable
Depends: libdvdread3 (>= 0.9.6) but it
is not installable
gnome-bin: Depends: libart2 (>= 1.2.13-5) but it is not installable
Depends: libgnorbagtk0 (>= 1.2.13-5) but it is not
installable
Depends: liborbit0 (>= 0.5.17) but it is not installable
dirmngr: Depends: libksba8 (>= 1.0.0) but it is not installable
xscreensaver-gl: Depends: libgle3 but it is not installable
libopensc1: Depends: libpcsclite1 (>= 1.2.9-beta7-5) but it is not
installable libegroupwise6: Depends: libsoup2.2-7 (>= 2.2.2) but it is
not installable
mplayer: Depends: libdv4 but it is not installable
Depends: libtheora0 but it is not installable
Depends: libxvidcore4 (>= 1:1.0.0-0.0) but it is not
installable
libglade-gnome0: Depends: libart2 (>= 1.2.13-5) but it is not
installable
Depends: libxml1 (>= 1:1.8.14-3) but it is not
installable
gstreamer0.10-plugins-good: Depends: libdv4 but it is not installable
Depends: libshout3 but it is not
installable
Depends: libtheora0 but it is not
installable
libft-perl: Depends: libttf2 but it is not installable
libpt-plugins-dc: Depends: libdv4 but it is not installable
libpt-plugins-avc: Depends: libdv4 but it is not installable
foomatic-db-hpijs: Depends: foomatic-filters but it is not
installable
Depends: foomatic-db but it is not installable
libakode2: Depends: libsamplerate0 but it is not installable
libgnomeui32: Depends: libart2 (>= 1.2.13-5) but it is not
installable
kdemultimedia-kfile-plugins: Depends: libtheora0 but it is not
installable
balsa: Depends: libcompfaceg1 but it is not installable
guile-1.6-dev: Depends: guile-1.6 but it is not installable
kommander: Depends: gettext but it is not installable
guile-library: Depends: guile-1.6 but it is not installable
libmime-perl: Depends: libconvert-binhex-perl but it is not
installable
g-wrap: Depends: guile-1.6 but it is not installable
gksu: Depends: sudo but it is not installable
libasound2-plugins: Depends: libsamplerate0 but it is not installable
libavcodec0d: Depends: liba52-0.7.4 but it is not installable
alsaplayer: Depends: alsaplayer-oss but it is not installable or
alsaplayer-output which is a virtual package.
foomatic-filters-ppds: Depends: foomatic-filters but it is not
installable
kfax: Depends: libtiff-tools but it is not installable
libavcodeccvs51: Depends: liba52-0.7.4 but it is not installable
Depends: liblame0 (>= 3.97) but it is not
installable
Depends: libtheora0 but it is not installable
Depends: libxvidcore4 (>= 1:1.0.0-0.0) but it is
not installable
guile-1.6-slib: Depends: guile-1.6 but it is not installable
libglade0: Depends: libxml1 (>= 1:1.8.14-3) but it is not installable
gstreamer0.10-plugins-base: Depends: libtheora0 but it is not
installable
alsaplayer-common: Depends: libmikmod2 (>= 3.1.10) but it is not
installable
Depends: alsaplayer-alsa but it is not
installable or
alsaplayer-output which is a virtual
package.
libgnomeprint15: Depends: libart2 (>= 1.2.13-5) but it is not
installable
Depends: libgdk-pixbuf2 (>= 0.22.0) but it is not
installable Depends: libxml1 (>= 1:1.8.14-3) but it
is not installable
gpgsm: Depends: libksba8 (>= 1.0.0) but it is not installable
gnupg2: Depends: libksba8 (>= 1.0.0) but it is not installable
hpijs-ppds: Depends: foomatic-filters (>= 3.0.2) but it is not
installable
libgnorba27: Depends: liborbit0 (>= 0.5.17) but it is not installable
libgnomeprint-bin: Depends: libart2 (>= 1.2.13-5) but it is not
installable
Depends: libgdk-pixbuf2 (>= 0.22.0) but it is not
installable
Depends: libxml1 (>= 1:1.8.14-3) but it is not
installable
libxine1: Depends: liba52-0.7.4 but it is not installable
Depends: libtheora0 but it is not installable
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
alsaplayer-oss [0.99.76-9 (stable, now)]
debconf-utils [1.5.11 (stable, now)]
foomatic-db [20061031-1 (stable, now)]
foomatic-db-engine [3.0.2-20061031-1 (stable, now)]
foomatic-filters [3.0.2-20061031-1.2 (stable, now)]
gettext [0.16.1-1 (stable, now)]
guile-1.6 [1.6.8-6 (stable, now)]
liba52-0.7.4 [0.7.4-7 (stable, now)]
libart2 [1.4.2-34 (stable, now)]
libcompfaceg1 [1:1.5.2-4 (stable, now)]
libconvert-binhex-perl [1.119-2 (stable, now)]
libdate-manip-perl [5.44-5 (stable, now)]
libdv4 [1.0.0-1 (stable, now)]
libdvdread3 [0.9.7-2 (stable, now)]
libgdk-pixbuf2 [0.22.0-11 (stable, now)]
libgle3 [3.1.0-5.3 (stable, now)]
libgnorbagtk0 [1.4.2-34 (stable, now)]
libksba8 [1.0.0-1 (stable, now)]
liblame0 [3.97-0.0sarge1 (now)]
libltdl3 [1.5.22-4 (stable, now)]
libmikmod2 [3.1.11-a-6 (stable, now)]
liborbit0 [0.5.17-11.1 (stable, now)]
libosp4 [1.5.1.0-2 (now)]
libpcsclite1 [1.3.2-5 (stable, now)]
libsamplerate0 [0.1.2-2 (stable, now)]
libshout3 [2.2.2-1 (stable, now)]
libsoup2.2-7 [2.2.3-2sarge1 (now)]
libtheora0 [0.0.0.alpha7.dfsg-1.1 (stable, now)]
libtiff-tools [3.8.2-7 (stable, now)]
libttf2 [1.4pre.20050518-0.4 (stable, now)]
libxml1 [1:1.8.17-14 (stable, now)]
libxvidcore4 [2:1.1.2-0.1sarge1 (now)]
psfontmgr [0.11.10-0.1 (stable, now)]
sudo [1.6.8p12-4 (stable, now)]

Score is -1616

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
alien alsaplayer-esd cupsomatic-ppd debhelper debian-reference-common
debian-reference-en dfontmgr flashplayer-mozilla gcc-3.3-doc
gcc-3.4-doc
gconf gnome-audio hwdata intltool-debian libbonobo2
libdirectfb-0.9-20
libdivxdecore0 libefs1 libgal2.2-1 libgal2.2-common libgal23
libgconf11
libgdk-pixbuf-gnome2 libghttp1 libglade-perl libgnome-vfs-common
libgnome-vfs0 libgnome2-doc libguppi16 libgwrapguile1 libimlib2
libkpathsea3 liboaf0 libofx0c102 libopenct0 libsqlite0
libswt-mozilla3-java libswt-mozilla3-jni libsysfs1 libt1-5 libwww0
oaf
po-debconf realplayer samba-doc ttf-freefont w32codecs webmin
webmin-inetd
0 packages upgraded, 0 newly installed, 49 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 116MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 125955 files and directories currently installed.)
Removing alien ...
Removing alsaplayer-esd ...
Removing cupsomatic-ppd ...
Removing debhelper ...
Removing debian-reference-en ...
Removing debian-reference-common ...
Removing dfontmgr ...
Removing flashplayer-mozilla ...
Removing gcc-3.3-doc ...
Removing gcc-3.4-doc ...
Removing libgnome-vfs0 ...
Removing libgnome-vfs-common ...
Removing gnome-audio ...
Removing hwdata ...
Removing po-debconf ...
Removing intltool-debian ...
Removing libdirectfb-0.9-20 ...
Removing libdivxdecore0 ...
Removing libefs1 ...
Removing libgal2.2-common ...
Removing libgal2.2-1 ...
Removing libgal23 ...
Removing libgdk-pixbuf-gnome2 ...
Removing libghttp1 ...
Removing libglade-perl ...
Removing libgnome2-doc ...
Removing libguppi16 ...
Removing libgwrapguile1 ...
Removing libimlib2 ...
Removing libkpathsea3 ...
Removing libofx0c102 ...
Removing libopenct0 ...
Removing libsqlite0 ...
Removing libswt-mozilla3-java ...
Removing libswt-mozilla3-jni ...
Removing libsysfs1 ...
Removing libt1-5 ...
Removing libwww0 ...
Removing realplayer ...
Removing samba-doc ...
Removing ttf-freefont ...
No CIDSupplement specified for KochiGothic-Regular, defaulting to 0.
No CIDSupplement specified for KochiGothic-Regular-JaH, defaulting to 0.
Removing w32codecs ...
Removing webmin-inetd ...
Removing webmin ...
Stopping webmin: webmin.
Removing libbonobo2 ...
Removing gconf ...
Removing libgconf11 ...
Removing oaf ...
Removing liboaf0 ...

L550r:/home/bill# aptitude search '~b'
L550r:/home/bill#

The above 2 lines seem to indicate that the broken packages have been
fixed or removed, so I did:

L550r:/home/bill# aptitude purge samba
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Building tag database... Done
The following packages will be REMOVED:
samba{p}
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 7967kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 122341 files and directories currently installed.)
Removing samba ...
Stopping Samba daemons: nmbd smbdstart-stop-daemon: warning: failed to
kill 3148: No such process
.
Purging configuration files for samba ...
Removing configuration file /etc/default/samba...
Removing configuration file /etc/default/samba...
L550r:/home/bill# aptitude install samba
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following NEW packages will be installed:
samba
The following packages are RECOMMENDED but will NOT be installed:
smbldap-tools
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/3258kB of archives. After unpacking 7967kB will be used.
Writing extended state information... Done
Preconfiguring packages ...
Selecting previously deselected package samba.
(Reading database ... 122293 files and directories currently installed.)
Unpacking samba (from .../samba_3.0.24-6_i386.deb) ...
Setting up samba (3.0.24-6) ...
Generating /etc/default/samba...
Starting Samba daemons: nmbd smbd.

Since the smbldap-tools package was recommended I decided to install it.

L550r:/home/bill# aptitude install smbldap-tools
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Building tag database... Done
The following NEW packages will be automatically installed:
libconvert-asn1-perl libcrypt-smbhash-perl libdigest-md4-perl
libdigest-sha1-perl libio-socket-ssl-perl libjcode-pm-perl
libnet-ldap-perl libunicode-map-perl libunicode-map8-perl
libunicode-maputf8-perl libunicode-string-perl
The following NEW packages will be installed:
libconvert-asn1-perl libcrypt-smbhash-perl libdigest-md4-perl
libdigest-sha1-perl libio-socket-ssl-perl libjcode-pm-perl
libnet-ldap-perl libunicode-map-perl libunicode-map8-perl
libunicode-maputf8-perl libunicode-string-perl smbldap-tools
0 packages upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 1526kB of archives. After unpacking 4874kB will be used.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
Get:1 http://ftp.debian.org stable/main libconvert-asn1-perl 0.20-1
[40.9kB]
Get:2 http://ftp.debian.org stable/main libdigest-md4-perl 1.5-1
[19.7kB]
Get:3 http://ftp.debian.org stable/main libdigest-sha1-perl 2.11-1
[24.3kB]
Get:4 http://ftp.debian.org stable/main libio-socket-ssl-perl 1.01-1
[42.8kB]
Get:5 http://ftp.debian.org stable/main libjcode-pm-perl 2.06-1 [30.9kB]
Get:6 http://ftp.debian.org stable/main libnet-ldap-perl 1:0.33-2
[319kB]
Get:7 http://ftp.debian.org stable/main libunicode-map-perl 0.112-10
[480kB]
Get:8 http://ftp.debian.org stable/main libunicode-string-perl 2.09-1
[133kB]
Get:9 http://ftp.debian.org stable/main libunicode-map8-perl 0.12-3
[78.6kB]
Get:10 http://ftp.debian.org stable/main libunicode-maputf8-perl 1.11-2
[16.1kB]Get:11 http://ftp.debian.org stable/main libcrypt-smbhash-perl
0.12-1 [13.8kB]
Get:12 http://ftp.debian.org stable/main smbldap-tools 0.9.2-3 [326kB]
Fetched 1526kB in 3s (426kB/s)
Selecting previously deselected package libconvert-asn1-perl.
(Reading database ... 122341 files and directories currently installed.)
Unpacking libconvert-asn1-perl (from
.../libconvert-asn1-perl_0.20-1_all.deb) ...
Selecting previously deselected package libdigest-md4-perl.
Unpacking libdigest-md4-perl (from
.../libdigest-md4-perl_1.5-1_i386.deb) ...
Selecting previously deselected package libdigest-sha1-perl.
Unpacking libdigest-sha1-perl (from
.../libdigest-sha1-perl_2.11-1_i386.deb) ...Selecting previously
deselected package libio-socket-ssl-perl.
Unpacking libio-socket-ssl-perl (from
.../libio-socket-ssl-perl_1.01-1_all.deb) ...
Selecting previously deselected package libjcode-pm-perl.
Unpacking libjcode-pm-perl (from .../libjcode-pm-perl_2.06-1_i386.deb)
...
Selecting previously deselected package libnet-ldap-perl.
Unpacking libnet-ldap-perl (from
.../libnet-ldap-perl_1%3a0.33-2_all.deb) ...
Selecting previously deselected package libunicode-map-perl.
Unpacking libunicode-map-perl (from
.../libunicode-map-perl_0.112-10_i386.deb) ...
Selecting previously deselected package libunicode-string-perl.
Unpacking libunicode-string-perl (from
.../libunicode-string-perl_2.09-1_i386.deb) ...
Selecting previously deselected package libunicode-map8-perl.
Unpacking libunicode-map8-perl (from
.../libunicode-map8-perl_0.12-3_i386.deb) ...
Selecting previously deselected package libunicode-maputf8-perl.
Unpacking libunicode-maputf8-perl (from
.../libunicode-maputf8-perl_1.11-2_all.deb) ...
Selecting previously deselected package libcrypt-smbhash-perl.
Unpacking libcrypt-smbhash-perl (from
.../libcrypt-smbhash-perl_0.12-1_all.deb) ...
Selecting previously deselected package smbldap-tools.
Unpacking smbldap-tools (from .../smbldap-tools_0.9.2-3_all.deb) ...
Setting up libconvert-asn1-perl (0.20-1) ...
Setting up libdigest-md4-perl (1.5-1) ...
Setting up libdigest-sha1-perl (2.11-1) ...
Setting up libio-socket-ssl-perl (1.01-1) ...
Setting up libjcode-pm-perl (2.06-1) ...
Setting up libnet-ldap-perl (0.33-2) ...
Setting up libunicode-map-perl (0.112-10) ...
Setting up libunicode-string-perl (2.09-1) ...
Setting up libunicode-map8-perl (0.12-3) ...
Setting up libunicode-maputf8-perl (1.11-2) ...
Setting up libcrypt-smbhash-perl (0.12-1) ...
Setting up smbldap-tools (0.9.2-3) ...

Since there was no error message when samba was re-installed and
re-started, I hoped samba was OK, but that is not the case - got this
mail message again:

Message 1:
From ***@L550r Mon Apr 23 16:32:45 2007
Envelope-to: ***@L550r
Delivery-date: Mon, 23 Apr 2007 16:32:45 -0400
To: ***@L550r
Subject: Panic or segfault in Samba
From: root <***@L550r>
Date: Mon, 23 Apr 2007 16:32:40 -0400

The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 8977 (/usr/sbin/smbd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Debian. For information about the procedure for submitting bug reports,
please see http://www.debian.org/Bugs/Reporting or the reportbug(1)
manual page.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1212938560 (LWP 8977)]
0xb7f6d410 in ?? ()
#0 0xb7f6d410 in ?? ()
#1 0x00000001 in ?? ()
#2 0x00000000 in ?? ()

~
~
(END

???
Bill
Florian Kulzer
2007-04-23 21:58:06 UTC
Permalink
Post by Bill Shofner
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
The Samba 'panic action' script, /usr/share/samba/panic-action, was
called for PID 2540 (/usr/sbin/smbd).
[...]
Post by Bill Shofner
L550r:/home/bill# aptitude install -f
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
alsaplayer alsaplayer-common balsa dirmngr foomatic-db-hpijs
foomatic-filters-ppds g-wrap gksu gnome-bin gnucash gnupg2 gpgsm
gstreamer0.10-plugins-base gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly guile-1.6-dev guile-1.6-slib guile-library
hpijs-ppds kdemultimedia-kfile-plugins kfax kommander libakode2
libasound2-plugins libavcodec0d libavcodeccvs51 libegroupwise6 libft-perl
libglade-gnome0 libglade0 libgnomeprint-bin libgnomeprint15 libgnomeui32
libgnorba27 libmime-perl libofx1 libopensc1 libpt-plugins-avc
libpt-plugins-dc libxine1 mplayer xscreensaver-gl
[ snip: lots of library dependency problems ]
Post by Bill Shofner
Score is -1616
Accept this solution? [Y/n/q/?] y
alien alsaplayer-esd cupsomatic-ppd debhelper debian-reference-common
debian-reference-en dfontmgr flashplayer-mozilla gcc-3.3-doc gcc-3.4-doc
gconf gnome-audio hwdata intltool-debian libbonobo2 libdirectfb-0.9-20
libdivxdecore0 libefs1 libgal2.2-1 libgal2.2-common libgal23 libgconf11
libgdk-pixbuf-gnome2 libghttp1 libglade-perl libgnome-vfs-common
libgnome-vfs0 libgnome2-doc libguppi16 libgwrapguile1 libimlib2
libkpathsea3 liboaf0 libofx0c102 libopenct0 libsqlite0
libswt-mozilla3-java libswt-mozilla3-jni libsysfs1 libt1-5 libwww0 oaf
po-debconf realplayer samba-doc ttf-freefont w32codecs webmin
webmin-inetd
0 packages upgraded, 0 newly installed, 49 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 116MB will be freed.
Do you want to continue? [Y/n/?] y
Keep a copy of this list. You should try to reinstall these packages
once your system is fixed. (Only the ones that are not "lib..."; the
libraries should be installed automatically). I have the feeling that
the dependency problems were caused by debian-multimedia stuff. Please
post your full /etc/apt/sources.list.

[ snip: the packages are removed ]
Post by Bill Shofner
L550r:/home/bill# aptitude search '~b'
L550r:/home/bill#
The above 2 lines seem to indicate that the broken packages have been fixed
or removed,
Just to be clear: Something like that should never happen for an upgrade to the
next stable Debian release. We have to figure out where it went wrong.
Unfortunately I cannot tell if the underlying problem is also responsible for
your samba troubles.
Post by Bill Shofner
L550r:/home/bill# aptitude purge samba
[ snip: seems to go well ]
Post by Bill Shofner
L550r:/home/bill# aptitude install samba
[...]
Post by Bill Shofner
Setting up samba (3.0.24-6) ...
Generating /etc/default/samba...
Starting Samba daemons: nmbd smbd.
Since the smbldap-tools package was recommended I decided to install it.
L550r:/home/bill# aptitude install smbldap-tools
[...]
Post by Bill Shofner
libconvert-asn1-perl libcrypt-smbhash-perl libdigest-md4-perl
libdigest-sha1-perl libio-socket-ssl-perl libjcode-pm-perl
libnet-ldap-perl libunicode-map-perl libunicode-map8-perl
libunicode-maputf8-perl libunicode-string-perl smbldap-tools
0 packages upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
[ snip: all seems to go well ]
Post by Bill Shofner
Since there was no error message when samba was re-installed and
re-started, I hoped samba was OK, but that is not the case - got this mail
[...]
Post by Bill Shofner
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 8977 (/usr/sbin/smbd).
This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.
If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Debian. For information about the procedure for submitting bug reports,
please see http://www.debian.org/Bugs/Reporting or the reportbug(1)
manual page.
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1212938560 (LWP 8977)]
0xb7f6d410 in ?? ()
#0 0xb7f6d410 in ?? ()
#1 0x00000001 in ?? ()
#2 0x00000000 in ?? ()
What is the output of "apt-cache policy libc6"? (I don't remember if we
checked this one already.)

Also, I am starting to wonder if this could be related to bug #389494.

One more thing to try is to get rid of samba completely:

aptitude --purge-unused purge samba samba-common smbclient webmin-samba smbldap-tools

and then to reinstall only these packages:

aptitude install samba samba-common smbclient
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill Shofner
2007-04-23 23:48:49 UTC
Permalink
Post by Bill Shofner
Post by Bill Shofner
Post by Bill Shofner
After upgrading my sarge box to etch, I cannot print and samba no
longer works. When I re-boot I get the following message from
The Samba 'panic action' script, /usr/share/samba/panic-action,
was
Post by Bill Shofner
Post by Bill Shofner
called for PID 2540 (/usr/sbin/smbd).
[...]
Post by Bill Shofner
L550r:/home/bill# aptitude install -f
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
alsaplayer alsaplayer-common balsa dirmngr foomatic-db-hpijs
foomatic-filters-ppds g-wrap gksu gnome-bin gnucash gnupg2 gpgsm
gstreamer0.10-plugins-base gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly guile-1.6-dev guile-1.6-slib
guile-library
Post by Bill Shofner
hpijs-ppds kdemultimedia-kfile-plugins kfax kommander libakode2
libasound2-plugins libavcodec0d libavcodeccvs51 libegroupwise6
libft-perl
Post by Bill Shofner
libglade-gnome0 libglade0 libgnomeprint-bin libgnomeprint15
libgnomeui32
Post by Bill Shofner
libgnorba27 libmime-perl libofx1 libopensc1 libpt-plugins-avc
libpt-plugins-dc libxine1 mplayer xscreensaver-gl
[ snip: lots of library dependency problems ]
Post by Bill Shofner
Score is -1616
Accept this solution? [Y/n/q/?] y
alien alsaplayer-esd cupsomatic-ppd debhelper
debian-reference-common
Post by Bill Shofner
debian-reference-en dfontmgr flashplayer-mozilla gcc-3.3-doc
gcc-3.4-doc
Post by Bill Shofner
gconf gnome-audio hwdata intltool-debian libbonobo2
libdirectfb-0.9-20
Post by Bill Shofner
libdivxdecore0 libefs1 libgal2.2-1 libgal2.2-common libgal23
libgconf11
Post by Bill Shofner
libgdk-pixbuf-gnome2 libghttp1 libglade-perl libgnome-vfs-common
libgnome-vfs0 libgnome2-doc libguppi16 libgwrapguile1 libimlib2
libkpathsea3 liboaf0 libofx0c102 libopenct0 libsqlite0
libswt-mozilla3-java libswt-mozilla3-jni libsysfs1 libt1-5 libwww0
oaf
Post by Bill Shofner
po-debconf realplayer samba-doc ttf-freefont w32codecs webmin
webmin-inetd
0 packages upgraded, 0 newly installed, 49 to remove and 0 not
upgraded.
Post by Bill Shofner
Need to get 0B of archives. After unpacking 116MB will be freed.
Do you want to continue? [Y/n/?] y
Keep a copy of this list. You should try to reinstall these packages
once your system is fixed. (Only the ones that are not "lib..."; the
libraries should be installed automatically). I have the feeling that
the dependency problems were caused by debian-multimedia stuff. Please
post your full /etc/apt/sources.list.
[ snip: the packages are removed ]
Post by Bill Shofner
L550r:/home/bill# aptitude search '~b'
L550r:/home/bill#
The above 2 lines seem to indicate that the broken packages have
been fixed
Post by Bill Shofner
or removed,
Just to be clear: Something like that should never happen for an upgrade to the
next stable Debian release. We have to figure out where it went wrong.
Unfortunately I cannot tell if the underlying problem is also
responsible for
your samba troubles.
Post by Bill Shofner
L550r:/home/bill# aptitude purge samba
[ snip: seems to go well ]
Post by Bill Shofner
L550r:/home/bill# aptitude install samba
[...]
Post by Bill Shofner
Setting up samba (3.0.24-6) ...
Generating /etc/default/samba...
Starting Samba daemons: nmbd smbd.
Since the smbldap-tools package was recommended I decided to install
it.
Post by Bill Shofner
L550r:/home/bill# aptitude install smbldap-tools
[...]
Post by Bill Shofner
libconvert-asn1-perl libcrypt-smbhash-perl libdigest-md4-perl
libdigest-sha1-perl libio-socket-ssl-perl libjcode-pm-perl
libnet-ldap-perl libunicode-map-perl libunicode-map8-perl
libunicode-maputf8-perl libunicode-string-perl smbldap-tools
0 packages upgraded, 12 newly installed, 0 to remove and 0 not
upgraded.
[ snip: all seems to go well ]
Post by Bill Shofner
Since there was no error message when samba was re-installed and
re-started, I hoped samba was OK, but that is not the case - got
this mail
[...]
Post by Bill Shofner
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 8977 (/usr/sbin/smbd).
This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which
shows
Post by Bill Shofner
the state of the program at the time the error occurred. The Samba
log
Post by Bill Shofner
files may contain additional information about the problem.
If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the
Samba
Post by Bill Shofner
binaries. Then submit the provided information as a bug report to
Debian. For information about the procedure for submitting bug
reports,
Post by Bill Shofner
please see http://www.debian.org/Bugs/Reporting or the reportbug(1)
manual page.
(no debugging symbols found)
Using host libthread_db library
"/lib/tls/i686/cmov/libthread_db.so.1".
Post by Bill Shofner
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1212938560 (LWP 8977)]
0xb7f6d410 in ?? ()
#0 0xb7f6d410 in ?? ()
#1 0x00000001 in ?? ()
#2 0x00000000 in ?? ()
What is the output of "apt-cache policy libc6"? (I don't remember if we
checked this one already.)
L550r:/home/bill# apt-cache policy libc6
libc6:
Installed: 2.3.6.ds1-13
Candidate: 2.3.6.ds1-13
Version table:
*** 2.3.6.ds1-13 0
500 http://ftp.debian.org stable/main Packages
100 /var/lib/dpkg/status
Post by Bill Shofner
Also, I am starting to wonder if this could be related to bug #389494.
aptitude --purge-unused purge samba samba-common smbclient
webmin-samba smbldap-tools
L550r:/home/bill# aptitude --purge-unused purge samba samba-common
smbclient webmin-samba smbldap-tools
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following packages are unused and will be REMOVED:
libconvert-asn1-perl{p} libcrypt-smbhash-perl{p}
libdigest-md4-perl{p} libdigest-sha1-perl{p}
libjcode-pm-perl{p} libnet-ldap-perl{p} libunicode-map-perl{p}
libunicode-map8-perl{p}
libunicode-maputf8-perl{p} libunicode-string-perl{p}
The following packages will be REMOVED:
samba{p} samba-common{p} smbclient{p} smbldap-tools{p}
webmin-samba{p}
0 packages upgraded, 0 newly installed, 15 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 28.2MB will be freed.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
(Reading database ... 123182 files and directories currently installed.)
Removing smbldap-tools ...
Removing libnet-ldap-perl ...
Removing libconvert-asn1-perl ...
Removing libcrypt-smbhash-perl ...
Removing libdigest-md4-perl ...
Removing libdigest-sha1-perl ...
Removing libunicode-maputf8-perl ...
Removing libjcode-pm-perl ...
Removing libunicode-map-perl ...
Removing libunicode-map8-perl ...
Removing libunicode-string-perl ...
Removing samba ...
Stopping Samba daemons: nmbd smbdstart-stop-daemon: warning: failed to
kill 2556: No such process
.
Purging configuration files for samba ...
Removing configuration file /etc/default/samba...
Removing configuration file /etc/default/samba...
Removing smbclient ...
Removing samba-common ...
Purging configuration files for samba-common ...
dpkg - warning: while removing samba-common, directory `/var/log/samba'
not empty so not removed.
Removing webmin-samba ...
Purging configuration files for webmin-samba ...
Post by Bill Shofner
aptitude install samba samba-common smbclient
Re-installing samba ...

L550r:/etc# aptitude install samba samba-common smbclient
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Reading task descriptions... Done
Building tag database... Done
The following NEW packages will be installed:
samba samba-common smbclient
The following packages are RECOMMENDED but will NOT be installed:
smbldap-tools
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/9514kB of archives. After unpacking 23.4MB will be used.
Writing extended state information... Done
Preconfiguring packages ...
Selecting previously deselected package samba-common.
(Reading database ... 122517 files and directories currently installed.)
Unpacking samba-common (from .../samba-common_3.0.24-6_i386.deb) ...
Selecting previously deselected package samba.
Unpacking samba (from .../samba_3.0.24-6_i386.deb) ...
Selecting previously deselected package smbclient.
Unpacking smbclient (from .../smbclient_3.0.24-6_i386.deb) ...
Setting up samba-common (3.0.24-6) ...

Setting up samba (3.0.24-6) ...
Generating /etc/default/samba...
tdbsam_open: Converting version 0 database to version 3.
account_policy_get: tdb_fetch_uint32 failed for field 1 (min password
length), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 2 (password
history), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 3 (user must
logon to change password), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 4 (maximum
password age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 5 (minimum
password age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 6 (lockout
duration), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 7 (reset count
minutes), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 8 (bad lockout
attempt), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 9 (disconnect
time), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 10 (refuse
machine password change), returning 0
Importing accout for root...ok
Importing accout for daemon...ok
Importing accout for bin...ok
Importing accout for sys...ok
Importing accout for sync...ok
Importing accout for games...ok
Importing accout for man...ok
Importing accout for lp...ok
Importing accout for mail...ok
Importing accout for news...ok
Importing accout for uucp...ok
Importing accout for proxy...ok
Importing accout for www-data...ok
Importing accout for backup...ok
Importing accout for list...ok
Importing accout for irc...ok
Importing accout for gnats...ok
Importing accout for nobody...ok
Importing accout for Debian-exim...ok
Importing accout for bill...ok
Importing accout for identd...ok
Importing accout for sshd...ok
Importing accout for gdm...ok
Importing accout for saned...ok
Importing accout for messagebus...ok
Importing accout for steven...ok
Importing accout for haldaemon...ok
Importing accout for statd...ok
Importing accout for avahi...ok
Starting Samba daemons: nmbd smbd.

Setting up smbclient (3.0.24-6) ...


No error message e-mail this time. Let me see what I can see from the
wife's Windows computer....

When trying to add a printer on my wife's Windows XP machine I am asked
for a user name and password to connect to this computer. I supply the
username and password but am unable to connect to the printer. Is samba
finally running?
Post by Bill Shofner
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill
Greg Folkert
2007-04-23 23:57:17 UTC
Permalink
Post by Bill Shofner
When trying to add a printer on my wife's Windows XP machine I am asked
for a user name and password to connect to this computer. I supply the
username and password but am unable to connect to the printer. Is samba
finally running?
YES!

You have to add the user running as root:

smbpasswd -a username

There is more to it after that, but you get the drift now.

For an easier time, I;d also install "swat" and use in your browser:

http://localhost:901

Login as root and then configure away. SWAT seems to work much better
than any manual tweaking, as far as getting up and running.
--
greg, ***@gregfolkert.net

Novell's Directory Services is a competitive product to Microsoft's
Active Directory in much the same way that the Saturn V is a competitive
product to those dinky little model rockets that kids light off down at
the playfield. -- Thane Walkup
Florian Kulzer
2007-04-24 16:43:57 UTC
Permalink
[...]
Post by Bill Shofner
Post by Florian Kulzer
aptitude --purge-unused purge samba samba-common smbclient
webmin-samba smbldap-tools
L550r:/home/bill# aptitude --purge-unused purge samba samba-common
[...]
Post by Bill Shofner
Post by Florian Kulzer
aptitude install samba samba-common smbclient
Re-installing samba ...
L550r:/etc# aptitude install samba samba-common smbclient
[...]
Post by Bill Shofner
Setting up samba (3.0.24-6) ...
Generating /etc/default/samba...
tdbsam_open: Converting version 0 database to version 3.
account_policy_get: tdb_fetch_uint32 failed for field 1 (min password
length), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 2 (password history),
returning 0
account_policy_get: tdb_fetch_uint32 failed for field 3 (user must logon to
change password), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 4 (maximum password
age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 5 (minimum password
age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 6 (lockout duration),
returning 0
account_policy_get: tdb_fetch_uint32 failed for field 7 (reset count
minutes), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 8 (bad lockout
attempt), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 9 (disconnect time),
returning 0
account_policy_get: tdb_fetch_uint32 failed for field 10 (refuse machine
password change), returning 0
I am not sure what to make of these messages, but I have very little
experience in running a samba server. It seems like the daemons start up
OK now.

[...]
Post by Bill Shofner
Starting Samba daemons: nmbd smbd.
Setting up smbclient (3.0.24-6) ...
No error message e-mail this time. Let me see what I can see from the
wife's Windows computer....
When trying to add a printer on my wife's Windows XP machine I am asked for
a user name and password to connect to this computer. I supply the username
and password but am unable to connect to the printer. Is samba finally
running?
You have to set up the exported folders, printers, authorized users,
etc. again. Purging the samba packages removed all your configuration
files, but since we could not isolate the cause of your problem we did
not have much choice. See Greg's recent mail for tips about samba
administration.

I think you can now also restore the rest of your system (your libc6
version was OK, by the way.) I would do it like this:

1) Comment out all unofficial repositories (including debian-multimedia)
in your /etc/apt/sources.list.

2) Run "aptitude update" and then

aptitude search '~i!~Odebian'

to get a list of all unofficial/obsolete packages. Save this list of
packages. Verify that nothing important is on the list and run

aptitude remove '~i!~Odebian'

(Ask here if you are unsure about what is important.)

3) Now your system should be clean and it should be possible to
reinstall the Debian packages that were removed because they were
broken earlier.

4) After that has been done you can include debian-multimedia and other
unofficial repositories again in your sources.list. Make sure to
change "sarge" to "etch" where necessary. Then run "aptitude update"
and it should be possible to install all the extra packages you want
(e.g. w32codecs).
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Bill Shofner
2007-04-24 20:22:43 UTC
Permalink
Post by Bill Shofner
[...]
Post by Bill Shofner
Post by Florian Kulzer
aptitude --purge-unused purge samba samba-common smbclient
webmin-samba smbldap-tools
L550r:/home/bill# aptitude --purge-unused purge samba samba-common
[...]
Post by Bill Shofner
Post by Florian Kulzer
aptitude install samba samba-common smbclient
Re-installing samba ...
L550r:/etc# aptitude install samba samba-common smbclient
[...]
Post by Bill Shofner
Setting up samba (3.0.24-6) ...
Generating /etc/default/samba...
tdbsam_open: Converting version 0 database to version 3.
account_policy_get: tdb_fetch_uint32 failed for field 1 (min
password
Post by Bill Shofner
length), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 2 (password
history),
Post by Bill Shofner
returning 0
account_policy_get: tdb_fetch_uint32 failed for field 3 (user must
logon to
Post by Bill Shofner
change password), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 4 (maximum
password
Post by Bill Shofner
age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 5 (minimum
password
Post by Bill Shofner
age), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 6 (lockout
duration),
Post by Bill Shofner
returning 0
account_policy_get: tdb_fetch_uint32 failed for field 7 (reset count
minutes), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 8 (bad lockout
attempt), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 9 (disconnect
time),
Post by Bill Shofner
returning 0
account_policy_get: tdb_fetch_uint32 failed for field 10 (refuse
machine
Post by Bill Shofner
password change), returning 0
I am not sure what to make of these messages, but I have very little
experience in running a samba server. It seems like the daemons start up
OK now.
[...]
Post by Bill Shofner
Starting Samba daemons: nmbd smbd.
Setting up smbclient (3.0.24-6) ...
No error message e-mail this time. Let me see what I can see from
the
Post by Bill Shofner
wife's Windows computer....
When trying to add a printer on my wife's Windows XP machine I am
asked for
Post by Bill Shofner
a user name and password to connect to this computer. I supply the
username
Post by Bill Shofner
and password but am unable to connect to the printer. Is samba
finally
Post by Bill Shofner
running?
You have to set up the exported folders, printers, authorized users,
etc. again. Purging the samba packages removed all your configuration
files, but since we could not isolate the cause of your problem we did
not have much choice. See Greg's recent mail for tips about samba
administration.
I now have samba set up to share the printer with the Windows machines
on my network, which is all I need. Thanks very much for your help
Florian. Thanks also to Greg.
Post by Bill Shofner
I think you can now also restore the rest of your system (your libc6
1) Comment out all unofficial repositories (including
debian-multimedia)
in your /etc/apt/sources.list.
2) Run "aptitude update" and then
aptitude search '~i!~Odebian'
to get a list of all unofficial/obsolete packages. Save this list of
packages. Verify that nothing important is on the list and run
aptitude remove '~i!~Odebian'
(Ask here if you are unsure about what is important.)
I have done the above search and saved the list to a file. I do not
think there is anything important that could not be re-installed on the
list, but I would appreciate it if you would let me know if you agree.

L550r:/etc/apt# aptitude search '~i!~Odebian'
i acroread - Adobe Acrobat
Reader: Portable Document Format file viewi acroread-escript
- Adobe EScript Plug-In
i acroread-plugins - Plugins for Adobe
Acrobat(R) Reader
i alsaplayer - PCM player
designed for ALSA
i A gnome-gv - GNOME PostScript
viewer
i gtkhtml3.2 - HTML
rendering/editing library - bonobo component binaryi
ipchains - Network firewalling for Linux 2.2.x
i ipmasqadm - Utility for
configuring extra masquerading functionalityi
kernel-image-2.6.8-1-386 - Linux kernel image for
version 2.6.8 on 386.
i A libavcodeccvs51 - library to encode
decode multimedia streams - runtime fii A libavformatcvs51
- ffmpeg file format library
i A libavutilcvs49 - avutil shared
libraries
i libbio2jack0 - oss/alsa to jack
porting lib - runtime files
i libdb2 - The Berkeley
database routines (run-time files)
i libdb4.0 - Berkeley v4.0
Database Libraries [runtime]
i libdb4.1 - Berkeley v4.1
Database Libraries [runtime]
i libdns11 - DNS Shared Library
used by BIND
i libdns16 - DNS Shared Library
used by BIND
i libebook8 - Client library for
evolution address books
i libecal6 - Client library for
evolution calendars
i libedata-book1 - Backend library
for evolution address books
i libedata-cal5 - Backend library
for evolution calendars
i libedataserver3 - Utily library for
evolution data servers
i libegroupwise6 - Client library for
accessing groupwise POA through SOAP
i libfaac0 - an AAC audio
encoder - library files
i A libfaad0 - freeware Advanced
Audio Decoder - runtime files
i libflac6 - Free Lossless
Audio Codec - runtime C library
i libgcrypt1 - LGPL Crypto
library - runtime library
i libgcrypt7 - LGPL Crypto
library - runtime library
i libgnutls10 - GNU TLS library -
runtime library
i libgnutls11 - GNU TLS library -
runtime library
i libgnutls7 - GNU TLS library -
runtime library
i A libgpod1 - a library to read
and write songs and artwork to an iPodi libgtkhtml3.2-11
- HTML rendering/editing library - runtime files
i libhowl0 - Library for
Zeroconf service discovery
i libisc7 - ISC Shared Library
used by BIND
i A libjack0.80.0-0 - JACK Audio
Connection Kit (libraries)
i liblame0 - LAME Ain't an MP3
Encoder
i liblwres1 - Lightweight
Resolver Library used by BIND
i libmp4-0 - Freeware Advanced
Audio Decoder - runtime files
i libofx1 - library to support
Open Financial Exchange
i liboil0.2 - Library of
Optimized Inner Loops
i libopencdk4 - Open Crypto
Development Kit (OpenCDK) (runtime)
i libopenh323-1.15.2 - H.323 aka VoIP
library
i libopensc1 - SmartCard library
with support for PKCS#15 compatible smi libosp4
- Runtime library for OpenJade group's SP suite
i A libpostproccvs51 - postproc shared
libraries
i libpt-1.8.3 - Portable Windows
Library
i libreadline4 - GNU readline and
history libraries, run-time libraries
i libsigc++-1.2-5c102 - type-safe Signal
Framework for C++ - runtime
i libsoup2.2-7 - an HTTP library
implementation in C -- Shared library
i libtasn1-0 - Manage ASN.1
structures (runtime)
i A libtasn1-2 - Manage ASN.1
structures (runtime)
i A libx264-54 - x264 video coding
library
i libxvidcore4 - High quality ISO
MPEG4 codec library
i mozilla-acroread - Adobe Acrobat(R)
Reader plugin for mozilla / konqueror
i mplayerplug-in - MPlayer Plugin for
Netscape/Mozilla
i slang1 - The S-Lang
programming library - runtime version
i slang1a-utf8 - The S-Lang
programming library with utf8 support
i A sodipodi - Vector based
drawing program
i w32codecs - win32 binary codecs
i xprt-xprintorg - Xprint - the X11
print system (dummy)
Post by Bill Shofner
3) Now your system should be clean and it should be possible to
reinstall the Debian packages that were removed because they were
broken earlier.
4) After that has been done you can include debian-multimedia and other
unofficial repositories again in your sources.list. Make sure to
change "sarge" to "etch" where necessary. Then run "aptitude update"
and it should be possible to install all the extra packages you want
(e.g. w32codecs).
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
My sources.list points to 'stable'.
Thanks again.
Bill
Florian Kulzer
2007-04-25 19:17:42 UTC
Permalink
Post by Florian Kulzer
I think you can now also restore the rest of your system (your libc6
1) Comment out all unofficial repositories (including
debian-multimedia)
in your /etc/apt/sources.list.
2) Run "aptitude update" and then
aptitude search '~i!~Odebian'
to get a list of all unofficial/obsolete packages. Save this list of
packages. Verify that nothing important is on the list and run
aptitude remove '~i!~Odebian'
(Ask here if you are unsure about what is important.)
I have done the above search and saved the list to a file. I do not think
there is anything important that could not be re-installed on the list, but
I would appreciate it if you would let me know if you agree.
L550r:/etc/apt# aptitude search '~i!~Odebian'
[...]

I did not see anything critical in that list but it seems that you had
some stuff installed from debian-multimedia which is meanwhile available
in normal Debian. That was probably what screwed up the dist-upgrade to
Etch. (I think that this mentioned explicitly in the release notes,
BTW.)

As I said in my other mail: Keep this list around and, once you have
cleaned up your system, you can try to install all these packages (minus
the "lib..." ones) from the normal Debian repositories. After that is
all in place you can activate debian-multimedia again in your
sources.list and install those packages which are still not officially
part of Debian.

[...]
My sources.list points to 'stable'.
It is advisable to change that to "etch". If you keep "stable" then you
might get some unpleasant surprises once Lenny is released.
--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |
Continue reading on narkive:
Loading...